¡¿Tu dispositivo Android antiguo dejará de funcionar en 2021?!

Desde noviembre se descubrió que una gran serie de sitios web que usaran certificados «Let’s Encrypt» dejarían de funcionar para el 2021 en smartphones antiguos. Afortunadamente, gracias a una solución, la gran mayoría de los sitios web en Android seguirán trabajando bien el siguiente año.

Para entender fácilmente el problema, la idea es que Let’s Encrypt depende de un certificado multi-firmado para algunos dispositivos, como Androids con versiones 7.1.1 Nougat o más antiguas.

Hace unos dos meses, Let’s Encrypt reveló que terminaría su asociación el próximo septiembre del 2021, por lo que el certificado multi-firmado dejaría de funcionar en todos esos smartphones. Así que los sitios web y servicios que usen Let’s Encrypt para asegurar sus conexiones HTTPS no funcionarían más, y son muchísimos los sitios web que actualmente lo usan.

Let’s Encrypt asegura las conexiones mediante HTTPS

Afortunadamente para todos, la asociación entre IdenTrust y Let’s Encrypt ha sido renovada, aunque la solución trabajará un poquito diferente. De acuerdo con la investigación de Android Police, la solución es un poco rara. Sea como sea, funciona bien con los estándares de validación de certificados de seguridad, y aunque añada un paso extra a la cadena en algunos casos, las cosas deberían trabajar de forma fluida y segura.

Por lo tanto, los usuarios de smartphones antiguos Android y los suscriptores a Let’s Encrypt no deberán hacer nada para que esta nueva medida funcione en 2021, es decir, si a caso algunos desarrolladores checarán que todo esté funcionando bien, pero el usuario final ni siquiera notará el cambio. Por lo mismo, no será necesario usar navegadores con sus propios certificados de seguridad, como Firefox.

Al final del día, la solución no es definitiva ya que caducará para el 2024. Lo que sí es seguro es que quienes estén usando dispositivos con Android 7.1.1 o más antiguo, tendrán tres años para comprar un dispositivo más moderno. Tomando en cuanta que ya no reciben actualizaciones de seguridad, deberían actualizar a un smartphone más moderno.

¿Cuentas con un smartphone antiguo que esté en peligro?

Deja un comentario